
Cortex 7.0

Cortex Overview

Cortex 7.0 is the latest revision of Cortex, Motion Analysis Corporation's flagship motion tracking soft-
ware. Cortex uses Motion Analysis Motion Capture Cameras to capture the motion of retro-reflective
markers. This information is then processed in the Cortex software for analysis. The cornerstone of this
analysis is the Identifying Template. An Identifying Template describes the position of the markers, with
respect to one another, and uses this information to automatically identify the markers. Once identified, the
Cortex software has a number of analysis options available, including skeleton calculations, graphing, ki-
netics, kinematics, and much more. 
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Help (?) Icons

Clicking on the ? icons throughout the Cortex interface will launch pop-up help windows referencing the
information for that section or functional window of the software.

Figure 1.  Help Popup Icons
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System Calibration Overview

Clicking on the Calibrate... button will bring up the Calibration Wizard interface. The first window to ap-
pear is Select Calibration Variation (From Files). Each one of these options will step you through the cali-
bration process, whether you are setting up and calibrating for the first time or just doing a quick refine.

Figure 2.  Calibration... Button
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L-Frame Calibration

Figure 3.  Seed (L-Frame) Calibration Setup

The L-Frame defines the capture volume's coordinate system. All cameras do not need to see the L-Frame
to obtain a successful calibration.

The Calibration settings are mostly relevant for this step. The settings include:

• Calibration Up Axis
• Calibration Units
• The L-Frame's measurements
• Lens focal length for the first calibration
• Whether cameras are upside down or leaning left or right

Press the Next button to Collect and Calibrate.

Calibration with Wand

Figure 4.  Wand Calibration Setup

Duration

This parameter setting allows the user to set the desired time limit (in seconds) for the wand capture.

Length

This parameter setting allows the user to set the length of the wand head (in millimeters), measured from
the center of the end marker to end marker.
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Calibration with Wand Procedure

1. In the Wand Calibration box on the right hand side, set the wand length to your wand size. Make sure
that you are using only a three-point wand. 

2. Set the duration of the trial. The duration should be sufficiently long enough to wave the wand through
most of the volume that you want calibrated. Smaller volumes take less time to complete. 

3. Click the Next button and start waving the wand side to side and up and down through the volume.
You want to spend about 1/3 of the data collection time with the wand parallel to each of the three X,
Y, & Z axes. 

Figure 5.  Completed Calibration
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4. Once the wand calibration has been completed, Cortex will then begin processing the data. During the
calculation process, a popup screen will appear with the resulting calculated lens and 3D residuals.
These numbers will converge as the calibration nears the actual wand length and focal lengths of the
camera lenses.

Figure 6.  Wand Processing Status

5. Once completed, the camera lenses should be very close to what was installed on the camera body (e.g.
6.023 mm for 6 mm lenses). If this is the case, and the wand length is very close (e.g. within 0.10 mm
difference for a 500.00 mm wand) to the original wand length, then the calibration is complete.

6. Select Save Setup.

The processing is automatic. When it's done:

• The U,V residuals should be between 0.05 pixels and 2.0 pixels.
• The Wand Length Deviation should be comparable to the 3D residuals.

7. Select Finish if the residuals are acceptable.

Your system is now calibrated and ready for use.

Note:

The “SystemSetup.cal” file has been saved and will be automatically reloaded each time you start Cortex.

Note:

When you click on the Finish button in the step above, you will get a message stating “Calibration has been
saved”. This message indicates that the setup information is saved to a system folder. You need to select
File > Save Setup in this step, since the system folder will be overwritten each time a calibration is done. 
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Floor Calibration (Optional)
It is necessary to perform a floor calibration if your floor is uneven or if the L-Frame is placed in a location
that does not adequately represent a flat floor in the capture volume.

1. Select the Floor Calibration button in the first step of the Calibration Wizard. This will bring up the
Floor Calibration window.

Figure 7.  Floor Calibration Window

2. Place a marker in each corner of the capture volume. These markers can be any type, but must all be
the same.

3. Enter the value for the Marker Center to Floor. This is the distance from the floor (your y=0 plane for
Y-up) to the center of the markers (maybe 20 mm for pedestal makers).

Note:

This setting is used to adjust the floor level of the capture volume, based on the size of markers (in mm)
used to determine the plane of the volume floor. For example, if 12 mm markers are spread across the vol-
ume floor, a Marker Center to Floor value of 6mm (radius of marker) plus any base pad thickness would be
entered into this box.

4. Select the Next button again. 
5. You should now see how much the calibration origin was moved and rotated with a six number display

which stands for the XYZ and yaw, pitch and roll adjustments. 

Figure 8.  XYZ and Yaw, Pitch, and Roll Adjustments

6. Finally, click the Finish button.
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Note:

Make sure no other markers (ghost or otherwise) are visible in the 3D View, as it will tilt your new virtual
floor to average them in as well.

Possible Problems with Calibrations
• Wrong placement or measurements of the calibration L-frame. Verify all measurements and x, y, and z 

axes that are set. This can be found in the Tools > Settings > Calibration tab. 
• Check the brightness of the cameras and the use/non-use of masks. Remember to limit the use of 

masks and make them as small as possible if they are in line from the camera through the intended cap-
ture volume. If any markers go through a masked area, the data will be ignored.

• Too many extra marker images are possible causes for a bad calibration. Watch out for anything reflec-
tive such as extra markers, reflective material on shoes, shiny floors, and debris in carpeting.

• If calibration problems persist, contact support@motionanalysis.com.
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Suggested Workflows

The core steps in preparing for a motion capture session are:

• Establishing the working folder where data will be recorded
• Calibrating the System
• Preparing the MarkerSets that are needed for recording. These can be previously created MarkerSets or 

new MarkerSets can be created.

Note:

Regarding calibrating your system: If you have already calibrated your system for the day there is no need
to recalibrate your system prior to each data collection. You may find that if a camera is bumped or after a
few hours after setting up your system, that the calibration has shifted slightly. If this is the case, then it is
recommended that you re-run the Calibration Wizard and Update Calibration or Refine Cameras Posi-
tions. Please See Chapter 6, Live Mode—Calibration in the Cortex 7.0 Reference Manual for more infor-
mation about the calibration process.

Starting a New Capture Session Using a New MarkerSet

1. Launch Cortex.
2. Select a new working folder using the Quick Files... tool in Cortex.  

a.  Click the Quick Files… button in Cortex.

Figure 9.  Quick Files Button and Interface
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b.  Create the new capture folder by clicking on the New Folder... button. You can rename this folder 
as needed (e.g. Date, Subject Name, etc.).

c.  Select the new folder in the directory tree.

d.  Click Set As Working Folder.

Figure 10.  Set as a Working Folder

3. Calibrate the Motion Capture System 
a.  Select Live Mode in Cortex.

Figure 11.  Live Mode Button

Step 2b

Step 2d

Step 2c
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b.  Select Calibrate…

Figure 12.  Calibrate Button

c.  The Calibration Wizard will guide you through the rest of the calibration process. For more 
information on the Calibration Wizard, see page 6-3 in the Cortex 7.0 Reference Manual.  

Figure 13.  Calibration Wizard—Initial Screen

4. Save the calibration into the local folder using the File > Save Setup As… menu item.
Cortex 7.0 Quick-Start Guide 11



5. Create a New MarkerSet using the New… button from the MarkerSet tools. 

Figure 14.  New... MarkerSet Button

6. Save the MarkerSet using by right-clicking on the MarkerSet tab and selecting Save As…

Figure 15.  Right-Click MarkerSet Tab Menu

7. Create an Identifying Template for the new MarkerSet. For more information on this process see Chap-
ter 7, Live Mode—MarkerSets & Objects the Cortex 7.0 Reference Manual.

8. Save the MarkerSet with its Identifying Template by right-clicking on the MarkerSet tab and selecting
Save.
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9. If this is a MarkerSet that will be used in other Motion Capture sessions, copy it to the System Objects
folder.
a.  Click the Add/Remove button on the MarkerSet tools.

Figure 16.  Add/Remove... MarkerSet Button

b.  Select the MarkerSet by clicking on the MarkerSet name in the Local Objects list

Figure 17.  Load MarkerSet Interface

c.  Select the down arrow to push a copy of the MarkerSet into the System Objects folder.

d.  The MarkerSet is now available for reuse in other capture sessions.
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10. You are now ready to record captures using your new MarkerSet.

Starting a New Capture Session Using MarkerSets In the 
System Objects Folder

1. Launch Cortex.
2. Select a new working folder using the Quick Files... tool in Cortex.  

a.  Click the Quick Files… button in Cortex.

Figure 18.  Quick Files Button and Interface
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b.  Create the new capture folder by clicking on the New Folder... button. You can rename this folder 
as needed (e.g. Date, Subject Name, etc.).

c.  Select the new folder in the directory tree.

d.  Click Set As Working Folder.

Figure 19.  Set as a Working Folder

3. Calibrate the Motion Capture System.
a.  Select Live Mode in Cortex.

Figure 20.  Live Mode Button

Step 2b

Step 2d

Step 2c
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b.  Select Calibrate…

Figure 21.  Calibrate Button

c.  The Calibration Wizard will guide you through the rest of the calibration process. For more 
information on the Calibration Wizard, see page 6-3 in the Cortex 7.0 Reference Manual.  

Figure 22.  Calibration Wizard—Initial Screen

4. Save the calibration into the local folder using the File > Save Setup As… menu item.
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5. Make local copies of the MarkerSets that will be used.
a.  Click the Add/Remove button on the MarkerSet tools.

Figure 23.  Add/Remove... MarkerSet Button

b.  Select the MarkerSet by clicking on the MarkerSet name in the System Objects list
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Figure 24.  Load MarkerSet Interface

c.  Select the up arrow to push a copy of the MarkerSet into the working folder.

d.  The MarkerSet is now available for use in this capture session.

e.  MarkerSets are loaded by clicking on the check box in the Local Objects List.

6. Update each MarkerSet’s Identifying Template for the subject being tracked. 
a.  This can be done using the New Subject... tool.

The New Subject tool allows the software to automatically identify markers based on a Model Pose 
that you create when you make a template. The result is that if you use the same marker set repeatedly, 
you will not have to ID the new person each time the marker set is used. The marker identification is 
automatic and instant, saving you time. For more information, refer to the “New Subject Button...” 
section on page 3-11 in the Cortex 7.0 Reference Manual.
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Figure 25.  New Subject Button and Interface

b.  Alternately, the Identifying Template can be updated by recording a new range of motion and 
creating the template from that. See page 7-4 of the Cortex 7.0 Reference Manual for more 
information on this process.
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7. Save the updated MarkerSets by right-clicking on a MarkerSet’s tab and selecting Save.

Figure 26.  Right-Click MarkerSet Tab Menu

8. The MarkerSets are now ready for use in the current capture session.

Right-Click and Save
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